D-Link DCF-660W Wireless CF Type I Card – Support Forum

Problem with Dlink DCF-660W [D-Link DCF-660W Wireless CF Type I Card - 104537]

  • fabbers
  • Posts: 18
  • Join Date: 1 September 2003
Well I know i hexed myself by putting the glowing review on the site for this card. After 8 months of loyal service i'm now having issues with this card. It will intemittently drop the connection whilt synching or browsing the web. On occasion it will not attempt to even connect to a network (just keeps flashing forever) and some times the card doesn't initialise. Other times inserting the card produces a "card in slot not recognised" error. I've hard reset my iPaq 2210 and reloaded the drivers but it does appear to be hardware related. Do I need to send it back to you guys or to Dlink? Cheers, fabbers
  • Michael
  • Posts: 10920
  • Join Date: 15 April 2003
  • Location: Manchester UK
You would have to send it back to Dlink where they should replace under warranty. One thing where did you get the drivers for the unit? The DCF-660W only shipped with drivers for PPC-2002 and lower. -- Michael - eXpansys
  • fabbers
  • Posts: 18
  • Join Date: 1 September 2003
I got the drivers from here, http://support.dlink.com/faq/view.asp?prod_id=1350 I know they're only beta's but they've been running fine since i purchased. I also tried the official PPC 2003 drivers from dlink.co.uk with similar results http://www.dlink.co.uk/?go=jN7uAYLx/oIJaWVUC7wcU93ygJVYKOhST9vhLPG3yV3oWYl5kP98f8p8Nqtyr2xuRXbrwDACr85YWNvr3LLhJksVtendaoG+
  • trinitron
  • Posts: 2
  • Join Date: 13 January 2005
I'm having the same problems, seems to have only just happened.
  • garyducks
  • Posts: 2
  • Join Date: 9 December 2004
Just started to have problems with internet connection. Just upgraded to 1mb broadband (from 512k) - using same adsl wireless router. Not sure if that's a coincidence. Any thoughts?
;