D-Link DSL-604+ Wireless ADSL Router – Support Forum

Slow internet [D-Link DSL-604+ Wireless ADSL Router - 104294]

  • cafc
  • Posts: 4
  • Join Date: 4 January 2005
After a while the internet stops/gets very slow on the PC, while the laptop using a wireless card is fine. Are there any settings or something that might sort this out? Also I cannot get file or print sharing working, used to have file sharing working but not anymore. Its probably some small settings on the PC or laptop but not sure what, any ideas on that?
  • rperkin
  • Posts: 2535
  • Join Date: 12 August 2003
  • Location: UK
"internet stops/gets very slow" If things work fine on your laptop, then it looks like the router and network are OK and that this is something specific to the PC. If you are not already doing this, it will help if you regularly clear out any temporary files and assorted other 'rubbish' which can clog up a system. Use Programs | Accessories | System Tools | Disk Cleanup in each account. I also suggest that you run an adware cleaning tool such as SpyBot-S&D or Ad-Aware, or even both. I also recommend that you use a registry cleaning tool to clear out any other rubbish whcih can build up. I can recommend jv16 PowerTools - but this does need some care. If the problems still occur once you have cleaned out the PC, then post again. "cannot get file or print sharing working" Windows resource sharing relies on communication on ports 137, 138, 139. A common reason for it not working is that something, usually a software firewall (including Windows Firewall or ICF), is blocking communication on these ports. Check that you have allowed this communication - unless you are unduly paranoid it should be fine to allow all communication on all ports to/from all addresses in the router's subnet. Different products uses different terminology - you may need to set up a rule of a 'trusted zone'. Note also that some software firewall products have a reputation for slowing down a PC... Hope this helps
  • cafc
  • Posts: 4
  • Join Date: 4 January 2005
Thanks but none of those things make a difference - I already have them on the PC and laptop and its always done this. WIth the file/print sharing, what exactly do I need to check those for each of those things? Also why does turbo mode being on still not change the speed on the laptop, eg 11mbps and not 22mbps? Thanks
  • rperkin
  • Posts: 2535
  • Join Date: 12 August 2003
  • Location: UK
"none of those things make a difference" It's difficult to diagnose these things at a distance, so it's always a good idea to check out the 'obvious'. Having said that, there is no 'obvious' reason why one system should have an apparently 'faster' connection than another. What exactly is happening when you observe this? Where are the systems located? [You haven't given much detail - what machines are they? Running what operating system and version? What wireless cards and driver versions do you have? Are you using the vendor's utility program to manage the wireless connection?] "file/print sharing, what exactly do I need to check" If you have a software firewall running (including WinXP's Windows Firewall or ICF) then disable it temporarily. [You haven't said that you have a software firewall, nor what it is. ICF? ZoneAlarm? Sygate? Kerio?] "speed on the laptop, eg 11mbps and not 22mbps" What wireless card do you have? Unless it is based on a Texas Instruments wireless chipset, it is most unlikely to implement the 22 Mbit/s speed. D-Link cards which do usually have a + in the model name, eg DWL-650+, DWL-G650+ (Cardbus cards), DWL-520+, DWL-G520+ (PCI cards). There are similar cards from other vendors. For a little more info see this recent thread. Hope this helps
  • cafc
  • Posts: 4
  • Join Date: 4 January 2005
The PC is downstairs, laptop usually upstairs. After a while of working the PC just stops loading pages, it has the globe (i think, not sure) symbol in the corner whil trying to load, as if its not actually connected. Both Windows XP, the PC has SP2 though (not any different without either, as its had this problem before it was out). Windows is managing the wireless connection, not the d-link program. The wireless card is DWL-G650 (not +). Also have the latest drivers I think. Windows firewalls are all disabled, although both PC and laptop have Norton anti virus and firewall.
  • rperkin
  • Posts: 2535
  • Join Date: 12 August 2003
  • Location: UK
"wireless card is DWL-G650" That explains why you're only getting 11 Mbit/s. This model of card does not support 22 Mbit/s, so will operate at 11 Mbit/s which is the highest common speed with the router. "Norton anti virus and firewall" Test whether Norton Personal Firewall is causing the file/print sharing problem by temporarily disabling it. You should add the router's network addresses to the Trusted Zone. See here for how to do it. Suggest you select 'Use network address' with 192.168.0.0 and 255.255.255.0 as the network address and subnet mask (assuming you are using the default router settings). As far as the Internet speed issue goes: - you don't say how the PC is connected - does the system have sufficient physical memory? Suggest a minimum of 512 Mbyte - when the problem occurs, start Windows Task Manager (via Ctrl/Alt/Del) and check the Performance and Networking tabs. On the Processes tab, click the CPU column header twice to sort the processes by descending order of CPU usage. Where is all the time going? - also check Control Panel | Administrative Tools | Event Viewer and look for any unusual events Hope this helps
  • cafc
  • Posts: 4
  • Join Date: 4 January 2005
The PC is connected to the router, if thats what you mean. It has 512 RAM (same as the laptop). Ill check the task manager next time I get a chance.
  • chewyy01
  • Posts: 6
  • Join Date: 24 November 2004
I reccomend you check if anyone is using your wireless connection to use your internet. You can do this by going to the router configuration page and check under Summary and then DHCP Allocation Table and see how many computers are connected to your router. Maybe one of your neighbours is able to recieve your wireless signal. Probably unlikely but worth checking if there is an IP u don't recognise use WEP security

Try with the following steps for faster and better internet connection,

1.) Reset the wireless router by using the power switch on it or by unplugging it and plugging it back in.
2.)Place the wireless router in an ideal location. The higher it is, the better, but don't put it near metal objects.
3.)Get as close as possible to the router with whatever device you're trying to connect.
4.)Keep the router and your connecting device away from other electronics. You should especially keep away from phones, fax machines and microwaves. etc.,
5.)Adjust the Wifi antenna if it has one.
6.)Change the router's channel, especially if other wireless routers are nearby.

7.) Check the Start up programs and remove the unwanted
8.) Maintain a Decent Space limit at Hard drive

9.) Check for Malware, Spyware and bots
10.) Clear cookies and temporary history files
11.)Close unwanted background tasks if any
12.)Reset the modem
13.)Browse with latest and updated browser

14.)Download using torrents
15.)Upgrade your hardware

;