D-Link DSL-604+ Wireless ADSL Router – Support Forum

just bought dsl 604+ need step by step help [D-Link DSL-604+ Wireless ADSL Router - 104294]

  • asdhillon
  • Posts: 2
  • Join Date: 13 November 2003
  • Location: london
hi guys, i just bought a dsl 604+ i have no luck with setting up getting help from the customer services. could anyone possibly give me a basic step by step guide on how to set the router up, simple terminology please, cheers guys your help will be much appreciated!!! thanks
  • rperkin
  • Posts: 2535
  • Join Date: 12 August 2003
  • Location: UK
Since no-one else has picked up the gauntlet, I'll offer a few hints. Ill assume you're working with PCs under Windows XP. The DSL-604+ router also works with assorted other operating systems of course. For the basics on home networking and file and print sharing see this link. Have a browse round this and nearby pages it will tell you most of what you need to know about the tricky bits, which are all to do with configuring each PC under Windows, and *not* with the router, which should work almost straight out of the box. Setting up the router is straightforward. At its simplest you only need to set two things specific to your network: - Provide the access information for your ISP, that is your account logon details and password - Define the SSID (Service Set ID) for wireless communication, which is the same as your Workgroup name I recommend that you start simple: one PC connected to the router by Ethernet. This will allow you to configure the router and test the Internet connection. Add further PCs and wireless connections once the basics are working. At this stage do *not* have any software firewalls running. 1. Connect a microfilter to your phone socket. Connect from the microfilter to the router using the cable provided. You can use a telephone extension lead if needed in this case connect the extension lead to the phone socket, then the microfilter, then the router. 2. Connect your PC by Ethernet to the router using the cable provided. It doesn't matter which port you connect to 3. Power up the PC and the router. On the PC, fire up Internet Explorer (or any other browser). In the address bar enter: http://192.168.0.1/ Click on Login. The username and password are both initially set to admin 4. On the first page, headed Multiple PVC, complete the fields Login User Name Login Password Confirm Password All the others should be left at their default settings which should work OK in the UK. The VPI, VCI, Connection type and Encapsulation are all country, telecom provider and ISP dependent: VPI: 0 VCI: 38 Encapsulation: PPPoA VCmux (Note: LLC seems to be the default set on most D-Link kit sold in the UK and seems to work...) Authentication: CHAP The values above should work for *all* UK ISP ADSL services except Karoo. Their parent company, Kingston Communications in Hull is independent of BT and uses the following values: VPI: 1 VCI: 50 Encapsulation: PPPoA LLC Click Modify then Apply. If you are prompted to save the settings and reboot, defer this until later after you have made the next change. 5. Use the menu to select Wireless Configuration. Enter your SSID, that is, your Workgroup name. It is *essential* that you spell this *identically* wherever you give the SSID or Workgroup name. 6. Now go to Maintenance | Save Changes, and do just that. Wait for the router to save the configuration and reboot. When it has done so, you should see the login screen again it takes a couple of minutes. And that's it it should now be working. You just need to do a couple of things in Internet Explorer, and you're away! 7. In Internet Explorer, select Tools | Internet Options | Connections. If you have any dial-up connections set, click on 'Never dial a connection'. Now click 'LAN Settings...' and make sure nothing is checked. Click OK. Now click 'Setup...' Choose the 'Set up a home or small office network' option. Continue by clicking Next, then select 'No, let me choose another way to connect to the Internet' Choose the option which says '...through a residential gateway'. When you get to the Name Your Network window, enter your selected Workgroup name spelled *identically* to before.
  • rperkin
  • Posts: 2535
  • Join Date: 12 August 2003
  • Location: UK
... CONTINUED [Note: Strictly, the SSID and Workgroup name are different things and do not have to be the same. But it makes things simpler to set up if you make them the same throughout] There are a couple of further checks you should make: 1. Right click on My Computer and select Properties. Select the Computer Name tab, and ensure the Workgroup Name (not the description) is set correctly 2. Right click on My Network Places and select Properties, then View Details. You should see reference to your Internet connection and your Local Area Connection. Right click on this last and select Properties. In the central window, select Internet Protocol (TCP/IP) and click Properties. On the General tab, make sure that 'Obtain an IP address automatically' and 'Obtain DNS server address automatically' are both set. 3. If in Network Connections you see any reference to a Network Bridge (Miniport), delete it. This shows that the Network Setup Wizard has done something naughty. Things won't work too well if this appears... 4. Double click on My Network Places. Double click on Entire Network. Double click on Microsoft Windows Network. You should see an icon for your network with its Workgroup name. Double click, and you should see an icon for your PC (at this stage, it should be the only one). Double click and you should see the shared resources. [Note: The Network Setup wizard will have set these for you] ... and that's it. If all seems OK, do similar things on further PCs, either with Ethernet or Wireless connections. You don't need to do anything else with the router, just further Windows setup. Remember to always give the Workgroup name precisely, to check that there are no Network Bridges present, and that each PC is set up for TCP/IP with 'Obtain an IP address automatically'. When everything seems to be working, download the latest router firmware from: ftp://ftp.dlink.co.uk/dsl_routers_modems/dsl-604+/ Unzip it, and load it using the web-based router administration facility. It's under Maintenance | Update Firmware Add extra security by changing System Username and Password, and by setting WEP encryption. That's under Wireless Configuration. You can restrict access to specific wireless devices by giving the MAC address of each. In Configuration | Date / Time, set the NTP State to NTP enabled. The default NTP Server IP address is fine. On each PC you can add further security by running a software firewall. Don't use XP's ICF use a well known product such as ZoneAlarm or Sygate or BlackICE. All of these have superior facilities, and at least one is free for personal use. Just beware that use of a software firewall can interfere with access to shared resources on your network until you have it set up correctly. I'm sure I've probably missed something but in summary, the router is the easiest part to get working. Hope this helps if you need more info, just shout...
  • Mike L
  • Posts: 3
  • Join Date: 2 January 2004
  • Location: UK
Unfortunately I still can't get the wlan network to work. I still have a one-way ping problem....The "host"has IP of 192.168.0.3 and the "client" has IP of 192.168.0.2! The "host" will ping the router and the "client", but the "client" will only ping the router, Also, Network Wizard won't create a network on the host, at least it doesn't show it in Network Connections... please what can I do next..?
  • tompepper
  • Posts: 4
  • Join Date: 23 March 2004
I have just bought this router. I have windows 2000. From the moment i plugged it in the Status light started to flash on and off, is this ok or should it stay on ?. I cannot get my computer to recognise it. The adsl and wlan lights seem to indicate that they are ok, but I get no response at all from anything. I cannot get an internet connection or any other connection including the lan. I have tried to do what was asked in the flimsy manual, but nothing happens, I have also tried to get it working through Add Devices, but that does not recognise it either. Can anybody offer any advice please ? thankyou doc
  • Mahesh
  • Posts: 8300
  • Join Date: 14 April 2003
  • Location: Liverpool, UK
Doc - How are you accessing the router from your PC via a cable or wiFI dongle ? Can you access 192.168.0.1 from IE ? -- Mahesh - eXpansys
  • tompepper
  • Posts: 4
  • Join Date: 23 March 2004
Thankyou for your prompt reply. I am using the cable to ax the router. I think it may be a filter problem, as i appear now, after borrowing a microfilter to be able to ax the dlink setup page 192.168.0.1 (or whatever it is). It accepeted my changing the password from admin so i must have some sort of connect. However i noow appear to have exactly the same problem as this fellow. http://www.expansys.com/forumthread.asp?code=DSL-604GPLUS&thread=293 I can not acess the internet, only that pageat d-link. I am also on BTinternet the same as the guy having the same problem, so i wonder if its something to do with their adsl setup ? Everytime i try to click the ADD button for the page i get a popup saying I am Duplicating something or other ? Anyone any ideas on this strange occurennce? ps: I did the adsl line test in 'diagnose' and it passed.
  • rperkin
  • Posts: 2535
  • Join Date: 12 August 2003
  • Location: UK
"Status light started to flash on and off" This confirms that your router is alive and healthy! "the flimsy manual" The manual is on the CD. Print it off or read it on screen. My view is that it's not very good, but it *is* 67 pages long... "Everytime i try to click the ADD button for the page i get a popup saying I am Duplicating something or other" You should click Modify, then Apply. Not trying to be funny, but this is explicitly covered in the fairly detailed instructions near the beginning of this thread... Also covered is the need for filters and the specific settings for *all* UK ISPs providing ADSL connection. Hope this helps
  • tompepper
  • Posts: 4
  • Join Date: 23 March 2004
thanks for the help. i think it was a filter fault as when i changed it for another it magically worked. unless i also changed something when i retyped evertyhing in but i dont think so ? Anyway im now on line and its working fine for the internet. However the LAN dont seem to be working. I also have a laptop and another pc (pc number 3), thew laptop has a wireless card and can connect to the net through the router fine no probs. The problem i have with this and my other pc (number 3) is it cannot connect to the main internet gateway pc and none of my computers can see each other on the lan. I have 1 pc connected with cat 5 to a port on the router. Both my main pc internet gateway and the other pc (pc number 3) have their nic enabled and seem to be working fine. I have all 3 workgroups named the same. When i try to enter my wireless configuration in ssid, as you suggest in tip#5 i cannot enter anything into it at all, or even delete whats there and type in anything else. So i cant really follow past that step on your comprehensive guide to setting up the router. I suppose i have missed something obvious and i will kick myself when i have it pointed out. But you know what its like when you cant see the wood for the trees.
  • rperkin
  • Posts: 2535
  • Join Date: 12 August 2003
  • Location: UK
"main internet gateway pc" There is no 'gateway PC'. The router is the gateway. Suggest that you ensure that you are not running ICS by disabling the service. Use Control Panel | Administrative Tools | Services, scroll down to 'Internet Connection Firewall (ICF) / Internet Connection Sharing (ICS)', double click, click Stop, then set 'Startup Type' to Disabled. "none of my computers can see each other" The usual reason for this is that a software firewall (including WinXP's ICF) is blocking communication on ports 137, 138, 139. This is required for Windows Networking to work. The step above should take care of ICF - disable or uninstall any other software firewall products until you are happy everthing is working. You can enable them later - just make sure that they can communicate to all other PCs behind the router, that is addresses 192.168.0.1 - 192.168.0.254 "enter my wireless configuration in ssid, as you suggest in tip#5" This is on the router's Configuration | Wireless Configuration screen. The default SSID for the DSL-604+ is 'default' (without the quotes). Can't see what the problem might be here. but if you're really stuck, you could try setting the SSID on you other wireless devices to 'default' as well... Hope this helps
Hi there guys, just a quick query and I hope someone will be able to sort it out without much hassle! I just bought my DSL-604+ this afternoon and am trying to set it up but got a little stuck. From what I can gather, with the ISP here (BT Broadband) the password field and perhaps the username field are not validated so when I fill in the settings described above and then hit 'Connect' the Router thinks about it then returns an error message, 'LCP No response'. Does anyone know what I can do about this? Thanks for all your help.
  • rperkin
  • Posts: 2535
  • Join Date: 12 August 2003
  • Location: UK

For BT Broadband the settings should be:

Login Username: anything.anything@btbroadband.com

Login Password: anything (I use the password null)

An entry in the Password field is required or the router will complain. The connection is validated against the ADSL circuit, not the username / password combination.

The settings described above (VPI, VCI etc) are the defaults for the DSL-604+ when purchased in the UK, so other than the username/password setting the DSL-604+ should work straight out of the box with BT Broadband. Did for me...

Just a quick check:

- is your ADSL connection active? Have you had it working on an ADSL modem or another model router prior to the DSL-604+ ?

- is the router's ADSL LED on ?

- what entries do you see on the router's Maintenance | Event Log screen? You should see entries like:

[SNMP]Up 10 secs-Link:Ethernet Link Up

[DRIVER]Up 15 secs-Link:ADSL Link Up

[PPP]Up 19 secs-Connect:PPP LCP reaches open state

[PPP]Up 19 secs-Auth:PPP Start CHAP authentication

[PPP]Up 19 secs-Connect:PPP IPCP reaches open state

Hope this helps

;