D-Link DSL-604+ Wireless ADSL Router – Support Forum

D-Link DSL 604+ and DWL 900AP+ [D-Link DSL-604+ Wireless ADSL Router - 104294]

  • Birthe
  • Posts: 10
  • Join Date: 29 November 2003
I simply cannot make the DWL 900AP+ work wireless together with the DSL 604+. Neiter is it connecting to DWL-520+ or DWL-650+. I can only see the device on my computer by connecting it to the DSL 604+ by wired LAN. Can someone tell me what I'm doing wrong or tell me a place where the setup is described so even I can understand it. Thanks in advance Birthe
  • Mahesh
  • Posts: 8300
  • Join Date: 14 April 2003
  • Location: Liverpool, UK
Can you see 192.168.0.1 from your web browser ? I had the same issue last week. So I hard wired my laptop to the 604+ and configured it. I had to set the SSID for the first time, it should have done it automatically but it didn't. Once I hard wired the device and configured it was easy and everything worked. -- Mahesh - eXpansys
  • rperkin
  • Posts: 2535
  • Join Date: 12 August 2003
  • Location: UK
1. I guess that you want the DWL-900AP+ to act as a Repeater to extend the range of the DSL-604+ 2. I do not know whether the DWL-900AP+ and DSL-604+ are compatible with each other. This is essential since repeating and bridging are manufacturer-specific (generally, you can't expect products from different manufacturers to work together in these modes) and the functionality needs to be built into each product. 3. If they do work together, I believe (I can't test it because I don't have a DWL-900AP+) that you need to configure the MAC address of the DSL-604+ into the DWL-900AP+ and set it to Repeater mode. Find the MAC address on the sticker on the base of the DSL-604+ (it is unique) or listed on the Configuration | Ethernet IP Address screen. The *wireless* MAC address is 1 higher than this - you should be able to discover it with the Site Survey button. The D-Link US site has both a FAQ and Knowledgebase area for products. Have a look here and browse around. There is also a FAQ section on the D-Link Australia site, although it's much more limited. Find it here. As far as the ability to connect from your DWL-520+ and DWL-650+ is concerned, if you have both the DSL-604+ and DWL-900AP+ powered and within range and with default settings, it is possible that *both* will act as a DHCP server and confuse everything... However, I would have thought that the D-Link AirPlus utility supplied with the DWL-520+ should be able to find and list the two networks established by the repeater and access point with its Site Survey option? They are unique since the BSSID is related to the MAC address of the repeater or access point. Hope this helps EDIT: When I originally posted this I didn't have a DWL-900AP+ - but I do now :) See posts later in this thread...
  • Birthe
  • Posts: 10
  • Join Date: 29 November 2003
Thank you for all your help - this solved my problem. I just changed the MAC address as you suggested and now it is working really good. Birthe
  • Birthe
  • Posts: 10
  • Join Date: 29 November 2003
Yes I can see it - that was not my problem - but thanks for asking
  • rperkin
  • Posts: 2535
  • Join Date: 12 August 2003
  • Location: UK
Pleased you've got it working, Birthe. That's another fact to add about the DSL-604+ ... it works with the DWL-900AP+ access point. Nowhere in the DSL-604+ literature does it tell you how to extend your wireless network coverage, and nowhere in the DWL-900AP literature does it say that it works with the DSL-604+. So now we know!
  • muckipup
  • Posts: 7
  • Join Date: 19 December 2003
  • Location: UK
I had a similar question regarding the DSL-604+ but using the DWL-900AP+ in client mode (to connect a PS2). I spoke to D-Link support (who were very quick and efficient despite being 'dissed' on other web sites) who told me that they would be compatible but to use latest firmware for each.....now to go home and put the theory into practice!!
  • James T
  • Posts: 1
  • Join Date: 19 May 2004
I could also do with a little guidance, I also have the DWL - 900AP+. I type in 192.168.0.50 to get into the web interface and it aloows me in for a few seconds to browse the screens and then page can not be displayed appears when I click a n option. I've turned off the router (604+) left it on and various other things to no avail, I also find it hard getting to the logon screen for the access point too. Modem.Router works fine. Hope somone can help me prior Thanks in advance James
  • pettya
  • Posts: 11
  • Join Date: 31 May 2004
Here is the first time i've seen that D-Link have actually confirmed that the DWL-900AP+ can be used in repeater mode with a number of devices: See document on D-link site: http://www.dlink.com.au/tech/drivers/files/wireless/DWL-900AP+_Repeater.zip -------------------------------------------------------------------------------------------- "Note: The DWL-900AP+ in repeater mode will currently connect to another DWL-900AP+ (in AP mode only), DWL-1000AP+ (in AP mode only), DWL-1500, DI-764, DI-714P+, or a DI-614+ wireless router. Note 2: You cannot daisy chain Access Points in Repeater mode." -------------------------------------------------------------------------------------------- Although i don't see the DSL-604+ on this list... which is what i have. Guess i'll take a chance and buy the 900+
  • rperkin
  • Posts: 2535
  • Join Date: 12 August 2003
  • Location: UK
"i don't see the DSL-604+ on this list" I have yet to find *any* D-Link info that mentions the DSL-604+ working with other products. I believe the problem is that most info is US-oriented - and the DSL-604+ is not sold there... I can confirm that the two *do* work together. The D-Link US site has a reasonable FAQ about the DWL-900AP+ - goto here and enter DWL-900AP+ in the search box. Unfortunately it isn't all accurate. For example, the quote that you give above about daisy chaining the device in Repeater mode is contradicted by user experience. See this link. If I get time over the next few days I'll post some notes on using the DWL-900AP+ with the DSL-604+. Hope this helps
  • pettya
  • Posts: 11
  • Join Date: 31 May 2004
Any info on the this combination would be great. Having bought the 604+, I need to work out whether to take a loss on it and get something else... or take a chance and build on it. If i could find a store with a good returns policy i would be cheering. I called D-link tech support yesterday and they said that their testing indicates that the 2 do not work together. I told them its been done, and they said maybe UK devices are different to Aussie ones.
  • pettya
  • Posts: 11
  • Join Date: 31 May 2004
Just got a call from DLink sales... who say "of course the Aussie version of the 604+ works with the 900AP+. I tell people to do it all the time." I asked why its not in the doco... was told, "Must be an omission in the documentation for the 604 not to be listed in the compatible repeater models." I always worry when Sales dept says something works and the tech department says it doesn't!
;