Nokia N95 – Support Forum

Debranding N95 [Nokia N95 - 141579]

  • masseur
  • Posts: 390
  • Join Date: 15 April 2003
<small>thanks to selene for confirming I can post this :-)</small> pre requisites First, make sure you have downloaded and installed the Nokia PC Suite and that it recognises your phone when connected via USB Also, choose a product code from the list supplied by selene found in the sticky thread here Updating the product code Download the Nemesis Service Suite (NSS) from here and install When NSS is installed, close the Nokia PC Suite by locating its icon in the system tray (the area in the bottom right hand corner where the time is displayed), right click on it and choose exit. Open NSS and plug your N95 into a USB port using the data cable that was supplied with the phone. In the very top right hand corner of the NSS program there is a little icon, click it and the NSS will scan and find your phone. Once found you will see a tab in the main window called ''Phone Info''. Click on this and in the right hand pane of the main window the top box has an option called product code, and beside it a check box that says ''enable'' In this box type the product code you want to change to, and check the enable box. now click the ''write'' button at the bottom. It only takes a second or two and the code has been changed. Disconnect the phone and close the NSS. Update the phone to debrand so far only the product code for the phone has been changed so now you need to perform an update in order to have the firmware change to the generic version Run the Nokia Update Service which is found in the Nokia PC suite, or download from here ...and that is it. You have now fully debranded your Nokia N95 and will have all the functionality that Nokia intended! ...Unless I am very much mistaken!
  • Bakewell
  • Posts: 3
  • Join Date: 24 January 2007
Tried this, and loaded NSS OK, but there seems to be something missing - I get the following dialogue in the Device Info box: Reading Virtual USB device...Done. ->Serial: E149F48F, HW: 0.0 Testing Interfaces... ->USB DKU2....Supported. ->USB CA-53...Supported. Testing Directories... ->DCT4 Loaders Dir(''Flash'')......Found. -->0 file(s) found. -->Please copy the loaders first! ->ADSP Loaders Dir(''FlashUsb'')...Found. -->0 file(s) found. -->Please copy the loaders first! ->DCT3 Loaders Dir(''fls1sup'')....Found. -->0 file(s) found. -->Please copy the loaders first! ->Products Dir(''products'').......Not Found. Implies I need something else to allow NSS to see my N95? Any help appreciated.
  • antych
  • Posts: 26
  • Join Date: 3 May 2007
  • Location: London
This message is ok. switch to Phone Info Tab and then press scan.
  • wi99y
  • Posts: 13
  • Join Date: 12 July 2005
The only thing I would add is this..... Change the product code Back up the phone''s contents up with the back facility on the PC suite. Debrand Restore the phone''s contents from the restore facilty on the pc suite Change your product code BACK to it''s original number....... I say this only so if your phone needs replacing sometime in the future the insurance wil do all it can to stop coughing up for a new one. YOU MUST RESTORE WITH THE SAME PRODUCT CODE YOU BACKED UP WITH!! If you don''t then you will end up with a brick (an expensive one) but you can get out of trouble by doing a master reboot.
  • tch_burn
  • Posts: 97
  • Join Date: 19 April 2006
Hm, no matter what i try i just can''t get NSS to detect my handset. PC Suite finds it fine before i exit it, but NSS just won''t see a thing. Damn.
  • wi99y
  • Posts: 13
  • Join Date: 12 July 2005
Change it back to the original AFTER debranding !! that''s my point !
  • Matt74
  • Posts: 4
  • Join Date: 8 May 2007
I''m having the same problem, can''t get NSS to detect my N95. Anyone have any ideas? Is it true that NSS doesn''t work on Vista?
  • tch_burn
  • Posts: 97
  • Join Date: 19 April 2006
no idea about Vista, I''m on XP Pro
  • elinchrom
  • Posts: 52
  • Join Date: 16 October 2006
When you run NSS you need to select Virtual USB. I had same problem until I did that and phone in PC Suite mode.
  • bigloaf
  • Posts: 1
  • Join Date: 8 May 2007
Try right clicking on NSS icon on your Desktop. Properties Compatability Compatability Mode Tick box (Run this program in compatability mode for) Choose:- Windows XP (Service Pack 2) In Settings tick :- Disable visual themes In Privilege tick:- Run this program as an Administrator Apply. Worked for me in Vista!
  • Matt74
  • Posts: 4
  • Join Date: 8 May 2007
Cheers Bigloaf, that worked perfectly. Didn''t even know you could so that in Vista, great tip.
;